Resultados 1 al 10 de 10

Tema: No se pueden instalar todas las actualizaciones...

  1. #1

    Predeterminado No se pueden instalar todas las actualizaciones...

    Hola buenas, tengo ubuntu 11.10 y hoy me ha salido el siguiente error en el Gestor de actualizaciones, no se pueden instalar todas las actualizaciones, he mirado en google y aquí mismo en el buscador del foro y no he dado con la solución, he intentado ir a Configuración del sistema---->Origenes del software--->actualizaciones, para ver como tengo configurado las actualizaciones y yo creo que las tengo bien...tengo marcadas las casillas de SEGURIDAD, RECOMENDADAS Y NO SOPORTADAS. Bien lo que he hecho tras salirme la dichosa ventana de "no se pueden instalar todas las actualizaciones" es cerrar la ventana, te daba la opción de cerrar o actualización parcial, la he cerrado y ya en el gestor de actualizaciones le he dado a actualizar y se han actualizado algunas actualizaciones NO TODAS, habían actualizaciones de seguridad, recomendadas y otras actualizaciones. Precisamente y hay vienen mis dudas por qué no se han actualizado TODAS las de seguridad y recomendadas si las tengo activadas en Origenes de software. Esto hasta ahora no me había ocurrido, he intentado ser lo más explicativo posible, llevo en Ubuntu cerca de 6 meses y hasta ahora todas las actualizaciones de seguridad y recomendadas se me habían instalado sin problemas...

    Gracias de antemano...

  2. #2
    Viciadill@ Avatar de Crises
    Ubicación
    /home/crises
    Mensajes
    176

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Con qué actualizas, con el gestor gráfico y mediante terminal?

    Si usas terminal, prueba a actualizar con aptitude y no con apt-get.

    Saludos.
    "Copiar o cambiar un programa es ser pirata; no es verdad. Ser pirata es atacar naves." - Richard Stallman

    Sobremesa
    : Chasis: Antec P180 Black | MB: Asus Striker II Formula | CPU: Intel Core 2 Quad Q6600 @ 2.40 Ghz | RAM: 2x2Gb Kignston HyperX DDRII 800Mhz | GPU: XFX 9800 GTX+ | SSD: Samsung SSD 840 Pro 128Gb | HDD: 2Tb HDD Seagate | Fuente: NOX Pulsar 650W | SO: Archlinux (Openbox) + Windows 7.

    Portátil:
    MSI Wind U100 + Sandisk SSD 32Gb + 2Gb RAM | SO: Archlinux (Openbox).
    // Network: TL-WR1043ND + DD-WRT.

  3. #3

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Hola Crises, utilizo el Gestor de Actualizaciones, no tengo instalado aptitude...lo intentaré. Gracias por responder...

    Por otra parte, me he dado de alta en http://ubuntuforums.org/index.php y he preguntado esta duda y me han dicho esto :http://ubuntuforums.org/showthread.php?t=1859240. Esta en inglés y no tengo mucha idea, alguien que sea tan,tan, tan amable y me pueda decir en poca palabras el contenido, no quiero que me lo traduzcáis, simplemente que resumáis aquello que vosotros habéis entendido, lo he intentado con el Google Traductor, pero no es lo mio.....

  4. #4
    Viciadill@ Avatar de Crises
    Ubicación
    /home/crises
    Mensajes
    176

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    De normal, nunca he tenido que instalar el aptitude, siempre viene instalado, al menos a mí. Pero constata que lo tengas instalado y sinos, instalalo.

    Lo mejor es que actualices desde un terminal, pues puedes usar apt-get para paquetes requeridos, o aptitude para paquetes importantes, que creo que ese tú problema, que algunos paquetes importantes no se han instalado, porque el Gestor de Actualizaciones usa apt-get.

    También puede ser un problema del repositorio, que está caído, la mejor manera de saber si un repositorio está caído, es actualizar desde terminal, pues te muestra cuales están caídos.
    "Copiar o cambiar un programa es ser pirata; no es verdad. Ser pirata es atacar naves." - Richard Stallman

    Sobremesa
    : Chasis: Antec P180 Black | MB: Asus Striker II Formula | CPU: Intel Core 2 Quad Q6600 @ 2.40 Ghz | RAM: 2x2Gb Kignston HyperX DDRII 800Mhz | GPU: XFX 9800 GTX+ | SSD: Samsung SSD 840 Pro 128Gb | HDD: 2Tb HDD Seagate | Fuente: NOX Pulsar 650W | SO: Archlinux (Openbox) + Windows 7.

    Portátil:
    MSI Wind U100 + Sandisk SSD 32Gb + 2Gb RAM | SO: Archlinux (Openbox).
    // Network: TL-WR1043ND + DD-WRT.

  5. #5

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Hola, he seguido tus consejos..he hecho esto:
    sudo apt-get install aptitude
    sudo aptitude update ( Me han salido efectivamente un montón de paquetes que no estaban actualizados)

    Ahora, para instalar los paquetes que comando tengo que poner, he encontrado que tengo que poner esto, es cierto: sudo aptitude upgrade.

  6. #6
    Viciadill@ Avatar de Crises
    Ubicación
    /home/crises
    Mensajes
    176

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Eso de buscar está bien, ayuda. Google es tu amigo

    Efectivamente, el upgrade actualizará todos tus paquetes. Si usas el apt-get upgrade será sólo para paquetes requeridos, y para aptitude upgrade, lo hará con todos directamente, requeridos e importantes.

    Y recuerda, antes de preguntar aquí, pregúntale a Google, él normalmente sabe la respuesta.
    "Copiar o cambiar un programa es ser pirata; no es verdad. Ser pirata es atacar naves." - Richard Stallman

    Sobremesa
    : Chasis: Antec P180 Black | MB: Asus Striker II Formula | CPU: Intel Core 2 Quad Q6600 @ 2.40 Ghz | RAM: 2x2Gb Kignston HyperX DDRII 800Mhz | GPU: XFX 9800 GTX+ | SSD: Samsung SSD 840 Pro 128Gb | HDD: 2Tb HDD Seagate | Fuente: NOX Pulsar 650W | SO: Archlinux (Openbox) + Windows 7.

    Portátil:
    MSI Wind U100 + Sandisk SSD 32Gb + 2Gb RAM | SO: Archlinux (Openbox).
    // Network: TL-WR1043ND + DD-WRT.

  7. #7

    Talking Re: No se pueden instalar todas las actualizaciones...

    Gracias, ya te comentaré a ver que tal...de momento esperaré a recopilar más información del tema...Muchas gracias de verdad...

  8. #8

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Con Debian, la forma de actualizar todo era:
    Código:
    apt-get update
    apt-get dist-upgrade
    Y si alguna dependencia se rompe siempre ayudaba
    Código:
    apt-get -f install
    Saludos
    "Azar es el nombre científico de la ignorancia."
    MUY IMPORTANTE Lee el REF Lee las normas|ESCANEOS Y MÁS ONLINE GRATUITOS|Protocolo de desinfección
    En este subforo hay una COMPARATIVA DE ANTIVIRUS Y CORTAFUEGOS, donde se discuten esos temas. Entra al CHAT

  9. #9

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Gracias a todos ya resolví el problema, aunque parezca mentira se resolvió sólo, la única explicación que le doy es lo que me comentaron en otro foro http://ubuntuforums.org/showthread.php?t=1859240, y que es lo que me comentaron os preguntaréis, pues esto:

    Esta en inglés...

    Due to the fact that uploads to the repositories of the active development branch are asynchronous and uncoordinated, dependencies of certain packages may arrive later than the dependent package. This causes package management tools such as Update Manager, which are mainly meant to be used with stable releases of Ubuntu where the package archive is always consistent, to interpret the situation as requiring a dist-upgrade to install new packages and/or repair packages in a "reqreinst" (requires reinstallation) state. What Update Manager performs when doing a "Partial Upgrade" is a dist-upgrade.
    Traducido al castellano..de google traductor, perdonad la traducción chapucera


    Debido al hecho de que los envíos a los depositarios de la rama de desarrollo activo son asincrónicas y sin coordinación, dependencias de ciertos paquetes pueden llegar más tarde del paquete dependiente. Esto hace que las herramientas de gestión de paquetes, como gestor de actualizaciones, que están destinados principalmente a utilizarse con versiones estables de Ubuntu en el archivo de paquetes es siempre consistente, para interpretar la situación de que exige un dist-upgrade para instalar nuevos paquetes y / o paquetes de reparación en un "reqreinst" (reinstalación requiere) del estado. ¿Qué Update Manager realiza cuando se hace una "actualización parcial" es un dist-upgrade.
    Por cierto aunque se me haya solucionado el tema no descarto que haya otras soluciones como las aquí propuestas:

    sudo apt-get install aptitude
    sudo aptitude update
    sudo aptitude upgrade

    Gracias....

  10. #10

    Predeterminado Re: No se pueden instalar todas las actualizaciones...

    Si es el problema es el que indican no trabajaría con esos repositorios normalmente, porque el problema casi seguro se va a repetir, mejor usa un repositorio más estable si puedes evitar esos.

    Aunque quizás si para actualizar sólo usas apt-get dist-upgrade no te de esos problemas, pues no interprete que se necesita actualizar, puede que sea más inteligente.

    Saludos
    "Azar es el nombre científico de la ignorancia."
    MUY IMPORTANTE Lee el REF Lee las normas|ESCANEOS Y MÁS ONLINE GRATUITOS|Protocolo de desinfección
    En este subforo hay una COMPARATIVA DE ANTIVIRUS Y CORTAFUEGOS, donde se discuten esos temas. Entra al CHAT

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •