Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 10 de 12

Tema: 8800gt en linux , ventilador 100%

  1. #1
    Master Avatar de Fos
    Ubicación
    Sevilla
    Edad
    32
    Mensajes
    1,235

    Predeterminado 8800gt en linux , ventilador 100%

    buenas ,


    pues lo que dice el titulo , que se pone al 100% el fan y no hay manera. ¿Que puedo hacer?
    Acer 1810tz

  2. #2

    Predeterminado Re: 8800gt en linux , ventilador 100%

    Seguramente no tienes los drivers "oficiales" (propietarios) para la gráfica instalados, verdad? Lo digo porque yo hasta que no instalo los drivers propietarios de mi gráfica (7800gt) el ventilador siempre esta al 100%. (no viene al tema, pero me es imposible instalar los drivers de nvidia en debian)

    Deberías de haber puesto que distribución utilizas, por ejemplo, si usas ubuntu el problema de instalación de drivers es muy sencillo ya que el mismo sistema te dice que estan disponibles, para otras distros tendrás que mirarte esto:
    http://www.nvidia.com/object/unix.html

    A ver si aparece alguien un poco más puesto en el tema y comenta al respecto; yo lanzo una pregunta:
    ¿Es posible modificar la velocidad de los ventiladores de la gráfica sin tener los drivers propietarios instalados?

    Un saludo.

  3. #3
    Master Avatar de Fos
    Ubicación
    Sevilla
    Edad
    32
    Mensajes
    1,235

    Predeterminado Re: 8800gt en linux , ventilador 100%

    pues tengo ubuntu y los drivers son de la pagina official , que han salido hace nada .. quizas ayer o antes de ayer
    Acer 1810tz

  4. #4

    Predeterminado Re: 8800gt en linux , ventilador 100%

    Cita Iniciado por grestle Ver mensaje
    (no viene al tema, pero me es imposible instalar los drivers de nvidia en debian)
    Por cierto, ¿tienes los non-free activado?. Lo digo porque a mí con todo perfecto, en Lenny no hay paquete nvidia-glx!

    En cuanto al tema original pues intenta instalar y ejecutar nvclock.

    MacBook Pro 13'' 2010 | Nexus 4 | Yours to Discover (blog) | Entrad al IRC linux de N3D, #n3d-linux! | Normas y recomendaciones del foro.

  5. #5

    Predeterminado Re: 8800gt en linux , ventilador 100%

    Cita Iniciado por grestle Ver mensaje
    Seguramente no tienes los drivers "oficiales" (propietarios) para la gráfica instalados, verdad? Lo digo porque yo hasta que no instalo los drivers propietarios de mi gráfica (7800gt) el ventilador siempre esta al 100%. (no viene al tema, pero me es imposible instalar los drivers de nvidia en debian)

    Deberías de haber puesto que distribución utilizas, por ejemplo, si usas ubuntu el problema de instalación de drivers es muy sencillo ya que el mismo sistema te dice que estan disponibles, para otras distros tendrás que mirarte esto:
    http://www.nvidia.com/object/unix.html

    A ver si aparece alguien un poco más puesto en el tema y comenta al respecto; yo lanzo una pregunta:
    ¿Es posible modificar la velocidad de los ventiladores de la gráfica sin tener los drivers propietarios instalados?

    Un saludo.
    ¿Que problema tienes exactamente para instalar los drivers de nvidia?. Oriéntanos y dinos que error te da.

    Tampoco dices que versión de Debian usas, si usas Lenny con kernel 2.6.22 el problema pueda deberse a que intenta compilar con gcc 4.2 cuando el kernel está compilado con gcc 4.1.

    Yo ahora mismo tengo el driver 100.14.19 con debian lenny 32bits (por cierto, acabo de mirar en la web de nvidia y sacaron antes de ayer el driver 169.07), te cuento los pasos que doy para instalarlos (contando con que ya te has descargado el driver de nvidia de su página oficial y lo tienes a mano en el disco duro):

    1) Para empezar tienes que instalar los kernel headers a juego con el kernel que estás usando, en mi caso tengo instalado el paquete linux-image-2.6.22-3-k7 pues instalé los paquetes linux-headers-2.6.22-3 y el paquete linux-headers-2.6.22-3-k7

    2) Luego tienes que instalar el paquete build-essential

    3) Nos vamos a la consola pulsando CTRL+ALT+F1 nos logueamos como root y matamos las X tecleando el siguiente comando:
    Código:
    /etc/init.d/gdm stop
    Esto hace detenerse al servidor gráfico, este paso es necesario para poder instalar el driver de nvidia.

    4) Para curarte en salud si tienes instalado otro gcc (yo tengo instalado también el gcc4-2) teclea
    Código:
    export CC=gcc-4.1
    Con este comando decimos al sistema que compilador usaremos para instalar el driver, el driver se ha de compilar con la misma versión que se compiló el kernel.

    5) Nos movemos hasta donde esté el driver de nvidia y una vez allí tecleamos
    Código:
    sh NVIDIA-Linux-x86-100.14.19-pkg1.run
    (con teclear sh N y pulsar TAB vale)

    6) Te saltará el instalador y es más o menos dar a siguiente, siguiente, y cuando te pregunte si quieres que busque en el ftp de nvidia por nosequé del kernel le dices que no, por ultimo si todo ha ido bien te preguntará que si quieres que él mismo te cambie el xorg.conf para que use el driver de nvidia le respondes que no (a mi por lo menos me da siempre problemas así que prefiero editarlo a mano)

    7) Editamos el archivo xorg.conf, con
    Código:
    cd /etc/X11 && nano xorg.conf
    y en el archivo buscamos algo como esto
    Código:
    ....
    Section "Module"
            Load    "i2c"
            Load    "bitmap"
            Load    "ddc"
            Load    "dri"
            Load    "extmod"
            Load    "freetype"
    .....
    añadimos la línea
    Código:
    Load    "glx"
    si no la tenemos ya y más abajo buscamos algo como esto
    Código:
    ....
    Section "Device"
            Identifier      "Tarjeta de vídeo genérica"
            Driver          "nv"
    .....
    sustituimos Driver "nv" por Driver "nvidia" y debajo de esta línea podemos añadir Option "nologo" para que al iniciar no salga el logo de nvidia, guardamos el archivo y ya podemos reiniciar el servidor gráfico con
    Código:
    /etc/init.d/gdm restart
    si todo ha ido bien debería iniciarse las X con el driver ya instalado y funcionando. Si queremos ver si funciona realmente el driver tecleamos en consola
    Código:
    glxinfo | grep render
    y debe salir
    Código:
    direct rendering: Yes
    Respecto a lo del ventilador yo no tengo ni idea, he instalado el paquete nvclock-gtk y a mi por lo menos no me aparece ninguna opción para toquetear la velocidad de los ventiladores, lo que si que pone es que necesitas el driver nvidia para poder usarlo, tengo una XFX GF7600GT en AGP.
    Última edición por tolyluis; 28/01/2008 a las 15:31 Razón: Añadidas algunas explicaciones


    ¿Por que te conformas con un windows cuando tienes un /home para ti entero? Usa GNU/Linux

  6. #6
    Master Avatar de josort
    Ubicación
    En el Ramón Sánchez Pizjuán
    Mensajes
    1,534

    Predeterminado Re: 8800gt en linux , ventilador 100%

    Yo también he tenido el mismo problema con Ubuntu. Y creo que es algún fallo que hay en el driver que hace que el ventilador gire constantemente al 100% produciendo un sonido insoportable.

    Yo lo solucioné con la siguiente guía.

    http://ubuntuforums.org/showthread.php?p=4010312

    Saludos.
    Super Flower Golden Silent Fanless 500W - EVGA DG-77 - MSI B450 Gaming Pro Carbon AC - AMD Ryzen 3 1200 - 2x8GB Ballistic Sport - AMD Radeon R9 Nano - Intel SSD 660p 512Gb - HP LP2465 - Unicomp ULtra Classic Black - Windows 10 Pro 64 bits
    Macbook - 4Gb DDR3 - Core 2 Duo 2,26Ghz - 250Gb - Geforce 9400M - OSX 10.12.1

  7. #7

    Predeterminado Re: 8800gt en linux , ventilador 100%

    hcakal
    Ya lo se ya: estaba con la stable y no podeia instalarlos entonces pase a testing y leyendo más vi que solo estaba para sid, actualice y luego de solucionar algunos que otros problemillas (de stable a sid pasando por testing no es de lo mejor..) los instalé, bueno, a decir verdad hice el proceso y no me dio ningun error xD
    El caso es que el ventilador seguia a lo suyo, 100% así que lo deje para más adelante.. :P

    tolyluis
    Muchas gracias por la guía, la última vez segui una bastante similar pero esta tiene algunos puntos que que la otra o bien obviaba o bien no era completa. Probaré a ver si tengo más suerte con esta, lo dicho, muchas gracias.

  8. #8

    Predeterminado Re: 8800gt en linux , ventilador 100%

    Nada hombre, espero que no tengas problemas para instalar el driver de nvidia.

    Feliz Navidad a tod@s.....


    ¿Por que te conformas con un windows cuando tienes un /home para ti entero? Usa GNU/Linux

  9. #9
    Master Avatar de marakaid
    Ubicación
    Mérida (Badajoz)
    Mensajes
    1,610

    Exclamation Re: 8800gt en linux , ventilador 100%

    Si te parece complicado lo de usar esa versión de "nvclock" prueba con los controladores "169.04 beta" .

  10. #10

    Predeterminado Re: 8800gt en linux , ventilador 100%

    Aunque sea un poco offtopic, la coletilla en los títulos de los temas "en linux" no es necesaria, por algo lo posteas dentro de un subforo dedicado (mucha gente lo hace, aunque cada vez menos )

Página 1 de 2 12 ÚltimoÚltimo

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •