Estoy utilizando OpenSsl 1.1.1, que es compatible con la versión TLS 1.3, y me gustaría crear unos certificados con esta versión.

Realmente no sé muy bien si realmente la versión de TLS es una propiedad del certificado o es más una configuración que se indica en el servidor, pero dado que OpenSsl es para crear certificados y se que a partir de las últimas versiones es compatible con la versión 1.3, me hace pensar que realmente es una propiedad del certificado y se debe de indicar en el momento de crear los certificados.

Pero he visto documentación y manuales cómo crear los certificados, incluso algún script, y nunca he visto que se indique la versión de TLS a utilizar, por lo que esto me hace dudar de si realmente estoy en lo correcto o no. O quizás OpenSsl siempre crea los certificados con la versión más nueva.

Así que en general, mi duda es un poco en saber bien qué es TLS y donde se establece, si en el certificado o el certificado no es de ninguna versión concreta de TLS y es más una confifuración del servidor, donde se indica la versión de TLS a utilizar en el comunicación con los clientes.



Muchas gracias.