Resultados 1 al 7 de 7

Tema: No se ejecuta correctamente FSTAB

  1. #1

    Predeterminado No se ejecuta correctamente FSTAB

    Hola, en casa tengo 3 ordenadores con diferentes versiones de Linux basadas en Ubuntu, y en los 3 tengo modificado el fstab para que monte una unidad de disco externa de red al iniciar el SO.

    Funciona todo bien, menos en el ordenador que he puesto Ubuntu 20.04LTS, en el cual a veces al encender el equipo está bien montada la unidad, pero otras veces en cambio no lo ha montado.

    Cuando falla, con ir a la terminal y ejecutar "sudo mount -a" ya lo monta correctamente, por lo que parece que el archivo fstab está bien (está igual que en los otros equipos), pero no llego a entender porqué a veces lo monta y a veces no.

    El equipo está recién formateado.

    ¿Alguna idea?
    P.D. soy usuario de Ubuntu, pero para nada un experto.

  2. #2

    Predeterminado Re: No se ejecuta correctamente FSTAB

    Buenas, pega tu fstab a ver si hay algo que pueda entrar en conflicto.

    Saludos
    "Azar es el nombre científico de la ignorancia."
    MUY IMPORTANTE Lee el REF Lee las normas|ESCANEOS Y MÁS ONLINE GRATUITOS|Protocolo de desinfección
    En este subforo hay una COMPARATIVA DE ANTIVIRUS Y CORTAFUEGOS, donde se discuten esos temas. Entra al CHAT

  3. #3

    Predeterminado Re: No se ejecuta correctamente FSTAB

    Este sería el contenido de fstab:

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    # / was on /dev/sda2 during installation
    UUID=21abf378-ae78-4b3a-9256-0a4838e2d11e / ext4 errors=remount-ro 0 1
    # /boot/efi was on /dev/sda1 during installation
    UUID=5B99-12F9 /boot/efi vfat umask=0077 0 1
    /swapfile

    //192.168.0.156/6TB /media/6TB cifs username=miusuario,password=mipassword,uid=1000,gi d=1000,user,rw,nounix,iocharset=utf8,file_mode=077 7,dir_mode=0777 0 0


    Acabo de quitar esa línea en blanco entre swapfile y la de la unidad de red, no se si puede tener algo que ver, como tampoco falla siempre.....
    Gracias zagloj por la respuesta, si ves algo mal en el archivo ya me dirás, saludos.

  4. #4

    Predeterminado Re: No se ejecuta correctamente FSTAB

    Buenas, disculpa que leí rápido la primera vez y no vi que era una unidad en red, veo también que usas CIFS, de ahí puede venir el problema, más que problema, causa, si cuando se intenta el montaje de las unidades la red no está disponible o no llega a ser accesible, el montaje fallará, simplemente sería revisar los logs. A parte, como casi todas las distros, Ubuntu incluida, usan systemd, cosa que yo no uso y espero jamás no usar, quizás necesites añadir esta opción
    Código:
    _netdev
    A las opciones de montaje, prueba y me dices, es para que espere a tener red antes de montar unidades y leer el fstab.

    Saludos
    "Azar es el nombre científico de la ignorancia."
    MUY IMPORTANTE Lee el REF Lee las normas|ESCANEOS Y MÁS ONLINE GRATUITOS|Protocolo de desinfección
    En este subforo hay una COMPARATIVA DE ANTIVIRUS Y CORTAFUEGOS, donde se discuten esos temas. Entra al CHAT

  5. #5

    Predeterminado Re: No se ejecuta correctamente FSTAB

    Muchas gracias por la explicación zagloj

    El modo de montar el disco de red utilizando CIFS es porque es la única manera que conseguí que funcionara, buscando por internet.
    Desconozco si hay otra manera mejor de hacerlo, unicamente quiero que esté accesible desde los 3 ordenadores de casa cuando los enciendo.
    Realmente no tengo muy claro que es CIFS ni systemd......

    De todas formas, he añadido al final de la línea _netdev, he probado a reiniciar varias veces y de momento no me a vuelto a fallar, así que parece que ha funcionado.

    Saludos!!!!!

    P.D. Que distro utilizas tú, si no es mucha indiscrección??

  6. #6

    Predeterminado Re: No se ejecuta correctamente FSTAB

    Buenas, de nada, CIFS es una opción más que correcta, porque a saber en qué formato está la partición que quieres montar, yo es que monto unidades NFS, pero es sólo para linux. En cuanto a mi distro, uso principalmente, desde 2006 gentoo, que es más una metadistro, es poco amigable para los recién llegados, no la recomendaría para empezar, a no ser que se tengan muchas ganas de aprender.

    Saludos
    "Azar es el nombre científico de la ignorancia."
    MUY IMPORTANTE Lee el REF Lee las normas|ESCANEOS Y MÁS ONLINE GRATUITOS|Protocolo de desinfección
    En este subforo hay una COMPARATIVA DE ANTIVIRUS Y CORTAFUEGOS, donde se discuten esos temas. Entra al CHAT

  7. #7
    El señor de los forillos Avatar de el_angel_caido
    Ubicación
    En un lugar de Asturias de cuyo nombre no quiero acordarme...
    Edad
    45
    Mensajes
    4,717

    Predeterminado Re: No se ejecuta correctamente FSTAB

    Hola.
    Cita Iniciado por zagloj Ver mensaje
    En cuanto a mi distro, uso principalmente, desde 2006 gentoo, que es más una metadistro, es poco amigable para los recién llegados, no la recomendaría para empezar, a no ser que se tengan muchas ganas de aprender.
    Perdón por el off-topic.

    ¿Poco amigable para los recién llegados, dice?
    ¿Salvo que tengas ganas de aprender?
    Mira que llevo años con Linux y he probado distros (ahora con Manjaro y Debian), y no soy experto pero tampoco novato (me falta meterme con scripting, sí, entre otras cosas "básicas")... pero no toco una Gentoo o una Slackware ni con el teclado de mi peor enemigo.

    Supongo que será la edad... pero me he puesto Manjaro porque Arch me parece tediosa de instalar y porque me cansaba andar con una distro con soporte limitado (de momento una semi rolling me va bien)... como para meterme con una Gentoo...

    Eso sí, olé por tí, zagloj, con un par... y Gentoo.

    Un saludo.
    Dios es ateo, no cree en mí.

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •