Resultados 1 al 5 de 5

Tema: Desactivar https en localhost en Chrome?

  1. #1
    Con domicilio en Noticias3d.com Avatar de Bakidok
    Mensajes
    6,441

    Predeterminado Desactivar https en localhost en Chrome?

    Buenas,

    Supongo que habrá sido alguna actualización de Chrome, pero hoy me encuentro que si accedo a localhost (para acceder a páginas que tengo en un wampserver) el Chrome me pone siempre el https delante, y claro no encuentra la página.

    He probado lo mismo en Firefox y funciona correctamente con http porque no cambia a https.

    He estado buscando en Google y no encuentro como desactivarlo... tenéis alguna idea de como quitarlo si se puede?

    Muchas gracias!

    - - - Actualizado - - -

    Parece que con esta solución funciona al principio pero luego navegas un poco o vuelves a cargar la página y vuelve a poner el https delante...
    https://superuser.com/questions/5654...ttps-in-chrome
    Última edición por Bakidok; 14/06/2021 a las 16:12
    PingStatus: Detecta cortes en tu conexión a Internet

    Intel Core i7-7700K@4.5Ghz | Corsair Hydro Series H115i Pro | MSI Z270 Gaming Pro Carbon | 32 GB DDR4 3000 MHz CL15 | Aorus GTX 1080 Ti Xtreme 11GB GDDR5X | Antec P100

  2. #2
    Master Avatar de skabeche
    Ubicación
    Unas veces en Benicàssim y otras en Oviedo
    Mensajes
    2,030

    Predeterminado Re: Desactivar https en localhost en Chrome?

    Esto me pasó no hace mucho, estaba utilizando xampp y al crear un virtualhost con el dominio .dev Chrome siempre me redireccionaba a https.
    Prueba con .local.site por ejemplo a ver que pasa.

    En todo caso, veo más útil y sencillo Lando (basado en Docker) para desarrollar en local https://lando.dev/ te olvidas de miles de configuraciones y en los que nunca encontré ese problema.
    SKIZOPHONIC
    Web de mi grupo: www.skizophonic.es
    Facebook de mi grupo: www.facebook.com/skizophonic
    Escúchanos en Spotify: Skizophonic en Spotify

    Si yo no soy Curro Jiménez ¿Por qué tengo este trabuco?

  3. #3
    Con domicilio en Noticias3d.com Avatar de Bakidok
    Mensajes
    6,441

    Predeterminado Re: Desactivar https en localhost en Chrome?

    Al final he creado un virtualhost para que no se llame localhost y ya está.
    Desconocia lo de Lando, le hecharé un vistazo a ver que tal, gracias!
    PingStatus: Detecta cortes en tu conexión a Internet

    Intel Core i7-7700K@4.5Ghz | Corsair Hydro Series H115i Pro | MSI Z270 Gaming Pro Carbon | 32 GB DDR4 3000 MHz CL15 | Aorus GTX 1080 Ti Xtreme 11GB GDDR5X | Antec P100

  4. #4

    Predeterminado Re: Desactivar https en localhost en Chrome?

    La cosa es que debido a Google y la evolución de la web, cuando no se especifica un protocolo, si está disponible Chrome prueba https antes que http. Efectivamente desactivando https en localhost que es lo que has hecho con el vhost hace que no haya https y por tanto aunque Chrome lo prueba, al no se accesible pues hace fallback a http.

  5. #5
    Master Avatar de skabeche
    Ubicación
    Unas veces en Benicàssim y otras en Oviedo
    Mensajes
    2,030

    Predeterminado Re: Desactivar https en localhost en Chrome?

    Lo curioso es que un virtualhost con .dev me redireccionaba siempre a https pero probé otros diferentes como .local o .site o incluso .local.site y funcionaba perfectamente sin redireccionar. Buscando info se ve que le pasaba a más gente pero todavía no he encontrado el porqué.
    SKIZOPHONIC
    Web de mi grupo: www.skizophonic.es
    Facebook de mi grupo: www.facebook.com/skizophonic
    Escúchanos en Spotify: Skizophonic en Spotify

    Si yo no soy Curro Jiménez ¿Por qué tengo este trabuco?

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •