Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 10 de 16

Tema: Kalarm no detecta archivos mp3

  1. #1

    Predeterminado Kalarm no detecta archivos mp3

    Hola, de nuevo.

    Como ya os dije en otro hilo, he instalado recientemente Debian 11 en mi pc y estoy, ahora mismo, tratando de "vestir al santo" (implementarlo con programas de mi interés). Parece ser, según he podido leer en google, que ese programa, Kalarm, no detecta archivos mp3. ¿Sabéis a que es debido? ¿Se puede corregir? Y si no es posible, ¿me podríais decir que tipo de archivos de audio detecta?

  2. #2

    Predeterminado Re: Kalarm no detecta archivos mp3

    Como alternativa, estoy tratando de instalar el Alarm-clock, pero no se deja. Cada vez que escribo los comandos de instalación por consola me responde que "no found", o sea, que me dice que faltan determinados paquetes, pero cuando trato de instalarlos a través del terminal me salta el siguiente error:

    ******@debian:~$ sudo apt-get install gconf2-common
    [sudo] password for *****:
    E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 9141 (synaptic)
    N: Be aware that removing the lock file is not a solution and may break your system.
    E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?


    ¿Sabéis a qué se debe? Gracias.
    Última edición por Johnny Flowers; 05/05/2022 a las 15:30

  3. #3

    Predeterminado Re: Kalarm no detecta archivos mp3

    Hola

    ¿Sabéis a qué se debe? Gracias.
    Se debe a que tienes abierto synaptic ( que hace lo mismo que apt, aunque en modo gráfico ). O bien lo tienes abierto, o bien se cerró a lo "bestia".

    Si lo tienes abierto, sal de él y el problema habrá desaparecido.
    Si no lo tienes abierto, comprueba si existe como un proceso "muerto". Esto lo puedes hacer desde una consola con la siguiente instrucción:

    $ ps -Af | grep "synaptic"

    Te devolverá una línea parecida a ésta:

    root nnnnnn mmmmm ..aquí varios campos... /usr/...../synaptic

    donde nnnnnn es el identificador de proceso y mmmmm es el identificador del proceso "padre".

    Si existe esa línea, tendrás que matar el proceso:

    $ sudo kill -9 nnnnnn

    Una vez hecho eso, podrás borrar el archivo /var/lib/dpkg/lock-frontend ( commo root ), y ya funcionará apt.

    Salu2
    Haz el amor y no la guerra

  4. #4

    Predeterminado Re: Kalarm no detecta archivos mp3

    Gracias, Roman13.

    Efectivamente, tenia abierto synaptic.

    He borrado lock-frontend como me has dicho, pero sigo sin poder instalar alarm-clock.

    Una vez me sitúo dentro de su directorio, en la consola, ordeno un ./configure y me sale esto:

    ******@debian:~/Descargas/Aplicaciones debian/alarm-clock-applet-0.3.4$ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether make supports nested variables... yes
    checking whether to enable maintainer-specific portions of Makefiles... yes
    checking whether make supports nested variables... (cached) yes
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking whether gcc understands -c and -o together... yes
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking whether to enable debugging... no
    checking whether gcc understands -Wall... yes
    checking whether gcc understands -Wstrict-prototypes... yes
    checking whether gcc understands -Wnested-externs... yes
    checking whether gcc understands -Werror=missing-prototypes... yes
    checking whether gcc understands -Werror=implicit-function-declaration... yes
    checking whether gcc understands -Werror=pointer-arith... yes
    checking whether gcc understands -Werror=init-self... yes
    checking whether gcc understands -Werror=format-security... no
    checking whether gcc understands -Werror=format=2... yes
    checking whether gcc understands -Werror=missing-include-dirs... yes
    checking what warning flags to pass to the C compiler... -Wall -Wstrict-prototypes -Wnested-externs -Werror=missing-prototypes -Werror=implicit-function-declaration -Werror=pointer-arith -Werror=init-self -Werror=format=2 -Werror=missing-include-dirs
    checking what language compliance flags to pass to the C compiler...
    checking for BASE... yes
    checking for GTK... yes
    checking for GSTREAMER... yes
    checking for GNOME... no
    configure: error: Package requirements (gconf-2.0
    gio-2.0
    gnome-icon-theme
    libnotify >= 0.4.1
    libxml-2.0
    unique-1.0) were not met:

    No package 'gconf-2.0' found
    No package 'unique-1.0' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GNOME_CFLAGS
    and GNOME_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    Parece que no están instalados los paquetes de dependencias gconf-2.0 ni unique-1.0.

    Cuando trato de instalar gconf me dice el sistema que ya está instalado en su versión más reciente. El otro paquete, unique-1.0, no lo encuentro en synaptic ni en google para su instalación en debian 11. ¿Cómo podría solucionar el asunto?

  5. #5

    Predeterminado Re: Kalarm no detecta archivos mp3

    En la página de alarm-clock-applet te dice:

    "....
    Check the README for dependencies. They're usually in the *-dev packages in most distributions. If you're on Debian / Ubuntu, install the following before running ./configure:
    $ sudo apt-get install libglib2.0-dev libgtk2.0-dev libgconf2-dev libgstreamer0.10-dev gnome-icon-theme libnotify-dev libxml2-dev libunique-dev libappindicator-dev
    ...."

    Si no has ejecutado esa línea, casi seguro que haciéndolo resuelves el problema.
    Haz el amor y no la guerra

  6. #6

    Predeterminado Re: Kalarm no detecta archivos mp3

    Esta es la respuesta que me da el terminal:

    ******@debian:~$ sudo apt-get install libglib2.0-dev libgtk2.0-dev libgconf2-dev libgstreamer0.10-dev gnome-icon-theme libnotify-dev libxml2-dev libunique-dev libappindicator-dev
    [sudo] password for *****:
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias... Hecho
    Leyendo la información de estado... Hecho
    El paquete libgstreamer0.10-dev no está disponible, pero algún otro paquete hace referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
    encuentra disponible desde alguna otra fuente

    E: El paquete «libgstreamer0.10-dev» no tiene un candidato para la instalación
    E: No se ha podido localizar el paquete libunique-dev
    E: No se ha podido localizar el paquete libappindicator-dev

  7. #7

    Predeterminado Re: Kalarm no detecta archivos mp3

    No vas a poder instalarlo seguramente.

    La ultima version del programa es la 0.3.4. Esa version, aparece en la seccion download de la web. Cuando das a descargar te lleva a launchpad y ahi aparece la fecha: Alarm Clock 0.3.4 Released: 2015-05-17

    El ultimo paquete disponible en debian via deb es de strecht (2017) -> https://packages.debian.org/stretch/alarm-clock-applet y servian la version 0.3.4, osea, la ultima disponible.
    Tambien te aparecen las dependencias. Puedes decargar el deb e intentar instalarlo. -> sudo dpkg -i nombre_del_paquete.deb

    Ese programa esta obsoleto, es de los tiempos de strecht. En su seccion instalacion, habla de realizarla desde las fuentes, que es lo que estas tratando de hacer.
    Toda esa informacion es antigua y sus dependencias estan obsoletas, el programa es viejo y ya no se mantienen. Salvo que estes corriendo debian stretch, yo me olvidaria de el. Por poner un ejemplo el paquete libunique-dev es de strecht y buster, no existe en bullseye.
    Última edición por UltimaNeurona; 08/05/2022 a las 11:48

  8. #8

    Predeterminado Re: Kalarm no detecta archivos mp3

    Al intentar instalar el paquete .deb, esta es la respuesta:

    ******@debian:~/Descargas/Aplicaciones debian$ sudo dpkg -i alarm-clock-applet_0.3.4-1+b1_amd64.deb
    Seleccionando el paquete alarm-clock-applet previamente no seleccionado.
    (Leyendo la base de datos ... 257071 ficheros o directorios instalados actualmente.)
    Preparando para desempaquetar alarm-clock-applet_0.3.4-1+b1_amd64.deb ...
    Desempaquetando alarm-clock-applet (0.3.4-1+b1) ...
    dpkg: problemas de dependencias impiden la configuración de alarm-clock-applet:
    alarm-clock-applet depende de libappindicator1 (>= 0.4.90); sin embargo:
    El paquete `libappindicator1' no está instalado.
    alarm-clock-applet depende de libunique-1.0-0 (>= 1.0.0); sin embargo:
    El paquete `libunique-1.0-0' no está instalado.

    dpkg: error al procesar el paquete alarm-clock-applet (--install):
    problemas de dependencias - se deja sin configurar
    Procesando disparadores para gnome-menus (3.36.0-1) ...
    Procesando disparadores para desktop-file-utils (0.26-1) ...
    Procesando disparadores para mailcap (3.69) ...
    Procesando disparadores para gconf2 (3.2.6-7) ...
    Procesando disparadores para hicolor-icon-theme (0.17-2) ...
    Procesando disparadores para man-db (2.9.4-2) ...
    Se encontraron errores al procesar:
    alarm-clock-applet

  9. #9

    Predeterminado Re: Kalarm no detecta archivos mp3

    Yo estoy totalmente de acuerdo con lo que te dice UltimaNeurona "...Salvo que estes corriendo debian stretch, yo me olvidaria de el...".

    Si aún así quieres intentar instalarlo, puedes descargar los paquetes que te faltan desde aquí:

    Para libunique-1.0-0, deberás bajar e instalar dos archivos.deb:
    Primero instalas este:https://packages.debian.org/buster/a...1.0-0/download
    Y si te deja, instala este otro:https://packages.debian.org/buster/a...e-dev/download

    Para libappindicator1, lo mismo:
    Primero este: https://packages.debian.org/buster/a...ator1/download
    Y si te ha dejado, instala este otro:https://packages.debian.org/buster/a...r-dev/download

    Esos archivos .deb, se instalan con la siguiente instrucción:
    $ sudo dpkg -i xxxx.deb

    Si tienes suerte te los instalará, aunque lo normal es que te de mensajes del tipo:
    "... xxxxx entra en conflicto con yyyyy ....".
    o bien:
    ".... xxxx depende de yyyyy pero la versión que hay instalada es la zzzz"
    En cualquiera de esos casos, deberías dejarlo. No te olvides entonces de desinstalar todo lo que hayas conseguido instalar.

    Es raro que te pase, pero podría ser que consigas instalar esos cuatro paquetes, y quizás entonces te funcionaría la instalación del paquete .deb que te bajaste de alarm-clock-applet.
    Aunque así fuese, yo también te recomendaría no instalarlo, y buscar alguna alternativa. Tarde o temprano ese paquete te dará conflictos con algunos otros, y si intentas resolverlos, cada vez el lío será mayor.

    Ese tipo de chapuzas sólo tienen sentido cuando necesitas mantener alguna aplicación antigua pero que te sigue siendo necesaria. Un ejemplo pueden ser los controladores de dispositivos obsoletos, pero que -por la razón que sea- se necesita que sigan funcionando.
    Última edición por roman13; 09/05/2022 a las 00:49
    Haz el amor y no la guerra

  10. #10

    Predeterminado Re: Kalarm no detecta archivos mp3

    Muchas gracias.

    Yo no sé que pasa con los despertadores en debian 11. El klarm no detecta los archivos mp3 y el alarm-clock, y otros que he intentado instalar antes, requieren un sin fin de dependencias.
    No se me ocurre ninguna alternativa que sea fácil de instalar y el reloj que viene de serie es tan sencillo que no te deja cambiar o introducir otros archivos de sonido (sólo produce un sonido insulso _pi, pi, pi..._ y débil)

Página 1 de 2 12 ÚltimoÚltimo

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •