Página 2 de 2 PrimerPrimer 12
Resultados 11 al 13 de 13

Tema: Ethernet Intel I225-v con Linux no funciona

  1. #11

    Predeterminado Re: Ethernet Intel I225-v con Linux no funciona

    Casi seguro que no tiene nada que ver, pero te cuento mi caso.

    Hace tres o cuatro meses cambié la placa base y pillé un nuevo nvme. Con el disco tuve movida, me lo tuvieron que cambiar, por lo que me tardó un par de semanas más de lo planeado. Mientras tanto probé de arrancar la placa nueva con el disco antiguo. Como funcionó -tocando alguna cosilla- lo deje así a la espera del nuevo disco, donde ya instalaría desde cero.

    Tardé dos o tres días en darme cuenta de que estaba funcionando con la wifi. Buscando lo que había pasado encontré que el nombre de la interfaz primaria de red en mi sistema ya no era eth0, sino eno1.

    Cambié "eth0" por "eno1" en las dos líneas del archivo /etc/network/interfaces, que quedaron así:
    .....
    # The primary network interface
    allow-hotplug eno1
    iface eno1 inet dhcp
    .....

    Reinicié y me funcionó.

    Como digo, casi seguro que no tenga nada que ver con tu caso, pero si quieres probar no tienes más que ejecutar:
    $ sudo dmesg | grep "eth"

    O también:
    $ sudo dmesg | grep "eno"

    Si te aparece algo como esto:
    [ 5.457710] r8169 0000:05:00.0 eno1: renamed from eth0

    Puedes probar a hacer el mismo cambio que yo hice en el archivo interfaces. Por supuesto que si trabajas con ips fijas en lugar de con DHCP, deberías hacer la modificación correspondiente.

    Salu2.
    Haz el amor y no la guerra

  2. #12
    Master
    Ubicación
    Valencia
    Mensajes
    1,757

    Predeterminado Re: Ethernet Intel I225-v con Linux no funciona

    Muchas gracias a todos por responder. Aunque no haya podido al final resolver el tema, siempre son útiles y muy didácticas las ideas, datos y enlaces aportados en este hilo. Al final de momento me voy a olvidar del tema. Con Linux voy a seguir tirando del Wifi que funciona bien con Internet. Si fuera imprescindible hubiera ido probando otras distros, pero de momento tengo otras prioridades a las que dedicarles tiempo.

  3. #13
    Master
    Ubicación
    Valencia
    Mensajes
    1,757

    Predeterminado Re: Ethernet Intel I225-v con Linux no funciona

    He conseguido que por fin me funcione la conexión Ethernet e Linux. Lo dejo aquí por si a alguien le es de utilidad. En mi caso la solución está en activar una opción llamada Pila de Red que por defecto está deshabilitada. Dentro de opciones Avanzadas en la BIOS está Pila de Red. Si tenéis la BIOS en inglés la opción aparecerá como "Network Stack". Al habilitar dicha opción Linux ya me ha reconocido la conexión Ethernet por cable y la ha activado.

Página 2 de 2 PrimerPrimer 12

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •